Navigation

Welche technischen Voraussetzungen gibt es für den Citavi Picker?

Der Citavi Picker setzt folgende Programmversionen voraus:

  • Internet Explorer ab Version11
  • Firefox ab Version 48
  • Google Chrome ab Version 30
  • Adobe Reader und Adobe Acrobat ab 10

Quelle:Citavi.com – Handbuch

Weitere Hinweise zum Webauftritt